码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4324 Triangle LOVE

时间:2014-07-29 12:24:16      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   java   color   os   strong   io   

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2306    Accepted Submission(s): 960


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

 

Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

 

Sample Output
Case #1: Yes Case #2: No
 

 

 

 

            题意:给你一个关系矩阵,比如i行j列的数值为1,带表i喜欢j。如果i喜欢j,则j一定不喜欢i,而且任何2个人之间都存在关系,要你判断是否存在一个三元环,A喜欢B,B喜欢C,C喜欢A。

           这道题我WA+MLE+TLE,最终还是没有过吧。本来想用DFS的,可惜超时了。

            

          网上的解题思路:此题可以一遍拓扑排序判环求解 即只需要找到一个环,就必定存在三元环 证明如下: 假设存在一个n元环,因为a->b有边,b->a必定没边,反之也成立所以假设有环上三个相邻的点a-> b-> c,那么如果c->a间有边,就已经形成了一个三元环,如果c->a没边,那么a->c肯定有边,这样就形成了一个n-1元环。。。。所以只需证明n大于3时一定有三元环即可,显然成立。

 

代码:

#include <stdio.h>
#include <string.h>
#define MAXN 2005

int Indegree[MAXN];
char str[MAXN][MAXN];

int main()
{
    int n, x, num, t, T, mark;
    scanf("%d", &T);
    for(int k = 1; k<=T; k++)
    {
        memset(Indegree, 0, sizeof(Indegree));
        mark = 0;

        scanf("%d", &n);
        for(int i = 0; i<n; i++)
        {
            scanf("%s", str[i]);
            for(int j = 0; j<n; j++)
            {
                x = str[i][j]-0;
                if(x)
                {
                    Indegree[j]++;  //记录每个节点的入度
                }
            }
        }

        for(int i = 0; i<n; i++)
        {
            for(t = 0; t<n; t++)   //若入度为0,则切断与它相连的所以路径
            {

                if(Indegree[t] == 0)
                    break;
            }
            if(t == n)     //形成了环。
            {
                mark = 1;
                break ;
            }
            else
            {
                for(int j = 0; j<n; j++)  //切断操作。
                {
                    if(str[t][j] == 1)
                    {
                        Indegree[j]--;
                    }
                }
            }
        }

        if(mark)
            printf("Case #%d: Yes\n", k);
        else
            printf("Case #%d: No\n", k);

    }

    return 0;
}

 

hdu 4324 Triangle LOVE,布布扣,bubuko.com

hdu 4324 Triangle LOVE

标签:des   style   blog   java   color   os   strong   io   

原文地址:http://www.cnblogs.com/fengxmx/p/3874787.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!