码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3555 —— Bomb

时间:2016-04-13 23:40:21      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:

Bomb

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 
Output
For each test case, output an integer indicating the final points of the power.
 
Sample Input
3
1
50
500
 
Sample Output
0
1
15

 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

typedef long long LL;

int a[20];
LL dp[20][2][2];

LL dfs(int u, bool is4, bool have, bool limit)
{
    if(u < 1)    return have;
    if(!limit && dp[u][is4][have] != -1)    return dp[u][is4][have];
    
    int maxn = limit ? a[u] : 9;
    LL ret = 0;
    
    for(int i=0; i<=maxn; i++) {
        ret += dfs(u-1, i==4, have||(is4&&i==9), limit&&i==maxn);
    }
    if(!limit)    dp[u][is4][have] = ret;
    return ret;
}

LL f(LL n)
{
    int len=0;
    while(n) {
        a[++len] = n%10;
        n /= 10;
    }
    return dfs(len, 0, 0, 1);
}

int main ()
{
    int T;
    LL n;
    scanf("%d", &T);
    memset(dp, -1, sizeof(dp));
    while(T--) {
        scanf("%lld", &n);
        printf("%lld\n", f(n));
    }    
    return 0;
}

 

HDU 3555 —— Bomb

标签:

原文地址:http://www.cnblogs.com/AcIsFun/p/5389202.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!