码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3252 —— Round Numbers

时间:2016-04-14 01:05:02      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
 

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone‘ (also known as ‘Rock, Paper, Scissors‘, ‘Ro, Sham, Bo‘, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can‘t even flip a coin because it‘s so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

int a[32];
int dp[32][32][32];

int dfs(int u, int zero, int one, bool limit, bool all0)
{
    if(u<1)    return     zero >= one;
    
    if(!limit && dp[u][zero][one] != -1)    return dp[u][zero][one];
    
    int maxn = limit ? a[u] : 1;
    int ret = 0;
    
    for(int i=0; i<=maxn; i++) {
        ret += dfs(u-1, !all0&&i==0?zero+1:zero, i==1?one+1:one, limit&&i==maxn, all0&&i==0);
    }
    if(!limit)    dp[u][zero][one] = ret;
    return ret;
}

int f(int n)
{
    int len=0;
    while(n) {
        a[++len] = n&1;
        n>>=1;
    }
    return dfs(len, 0, 0, 1, 1);
}

int main ()
{
    int l, r;
    memset(dp, -1, sizeof(dp));
    scanf("%d%d", &l, &r);
    printf("%d\n", f(r) - f(l-1));
    
    return 0;
}

 

POJ 3252 —— Round Numbers

标签:

原文地址:http://www.cnblogs.com/AcIsFun/p/5389363.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!