码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2506,Tiling

时间:2014-07-29 12:58:37      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:java   大数   递推   

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7528   Accepted: 3682

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.
bubuko.com,布布扣

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source


import java.math.BigInteger;
import java.util.Arrays;
import java.util.Scanner;


public class poj2506 {
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		BigInteger []f= new BigInteger[260];
		Arrays.fill(f, BigInteger.ZERO);
		f[0]=BigInteger.ONE;
		for (int i=0;i<=250;i++){
			f[i+1]=f[i+1].add(f[i]);
			f[i+2]=f[i+2].add((f[i].multiply(BigInteger.valueOf(2))));
		}
		while (cin.hasNext()){
			int n=cin.nextInt();
			System.out.println(f[n]);
		}
	}

}


java大数递推水过,递推f[i+1]和f[i+2]

题目大意:2xn的矩形用2x1和2x2两种矩形填充,一共有多少种填充方案













POJ2506,Tiling,布布扣,bubuko.com

POJ2506,Tiling

标签:java   大数   递推   

原文地址:http://blog.csdn.net/ieayoio/article/details/38261923

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!