标签:des style http java color os strong io
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16250 Accepted Submission(s): 5311
Problem Description
Now I think you have got an AC in Ignatius.L‘s "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don‘t want to write a special-judge module, so you don‘t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
求区间的和。。DP题。。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>
typedef __int64 LL;
using namespace std;
const int N=1000000+100;
const int INF = 0x3f3f3f3f;
LL a[N];
LL b[N];
LL dp[N];
LL Max;
int main()
{
int m, n;
while(scanf("%d%d", &m, &n)==2)
{
b[0] = dp[0] = 0;
for(int i=1; i<=n; i++)
{
scanf("%I64d", a+i);
b[i] = dp[i] = 0;
}
for(int i=1, j; i<=m; i++)
{
Max = -INF;
for(j=i; j<=n; j++)
{
if(b[j-1]>dp[j-1])
dp[j] = b[j-1] + a[j];
else
dp[j]=dp[j-1]+a[j];
b[j-1] = Max;
if(dp[j]>Max) Max = dp[j];
}
b[j-1] = Max;
}
printf("%I64d\n",Max);
}
return 0;
}
HDU 1024:Max Sum Plus Plus,布布扣,bubuko.com
HDU 1024:Max Sum Plus Plus
标签:des style http java color os strong io
原文地址:http://blog.csdn.net/u013487051/article/details/38253559