码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1312 Red and Black (bfs)

时间:2016-04-15 19:56:05      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
 
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
 
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

 

Output
 
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

 

Sample Input
 
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7 ..#.#..
..#.#.. ###.
### ...@...
###.### ..#.
#.. ..#.#..
0 0
 

 

Sample Output
 
45
59
6
13
#include<stdio.h>
#include<string.h>
#include<queue>
#define MAX 107
using namespace std;
int begin_x, begin_y;
int n, m, count;
char mapp[MAX][MAX];
int visited[MAX][MAX];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
    int x;
    int y;
};
int check(int x, int y)
{
    if(x >= 0 && x < n && y >= 0 && y < m && mapp[x][y] != # && visited[x][y] == 0)
        return 1;
    return 0;
}
void bfs(int x, int y)
{
    queue<node> q;
    struct node temp, next;
    temp.x = begin_x;
    temp.y = begin_y;
    q.push(temp);
    visited[temp.x][temp.y] = 1;
    while(!q.empty())
    {
        temp = q.front();
        q.pop();
        count++;
        for(int i = 0; i < 4; i++)
        {
            next.x = temp.x + dir[i][0];
            next.y = temp.y + dir[i][1];
            if(check(next.x, next.y))
            {
                q.push(next);
                visited[next.x][next.y] = 1;
            }
        }
    }
}
int main()
{
    while(scanf("%d%d", &m, &n)!=EOF && (n || m))
    {
        getchar();
        count = 0;
        memset(visited, 0, sizeof(visited));
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%c", &mapp[i][j]);
                if(mapp[i][j] == @)
                {
                    begin_x = i;
                    begin_y = j;
                }
            }
            getchar();
        }
        bfs(begin_x, begin_y);
        printf("%d\n",count);
    }
    return 0;
}

 

hdu 1312 Red and Black (bfs)

标签:

原文地址:http://www.cnblogs.com/burning-flame/p/5396587.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!