码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 2029】 Get Many Persimmon Trees(DP)

时间:2016-04-16 19:22:20      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:

【POJ 2029】 Get Many Persimmon Trees(DP)

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 4024   Accepted: 2628

Description

Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as ‘Mishirazu Persimmon‘, were planted. Since persimmon was Hayashi‘s favorite fruit, he wanted to have as many persimmon trees as possible in the estate given by the lord.
For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded by the solid line contains the most persimmon trees. Similarly, if the estate‘s width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate‘s width and height are 3 and 4 respectively, the area surrounded by the dotted line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.
技术分享
Figure 1: Examples of Rectangular Estates

Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.

Input

The input consists of multiple data sets. Each data set is given in the following format.

N
W H
x1 y1
x2 y2
...
xN yN
S T

N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <= N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.

The end of the input is indicated by a line that solely contains a zero.

Output

For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.

Sample Input

16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0

Sample Output

4
3


题目大意:有一个W*H的田野,里面有n棵树。

现在想用s*t的矩形篱笆圈出尽量多的树,问最多能圈出几棵树?


做法是遍历的过程中记录有用的数据,然后进行dp。

用一个数组记录单行长为t的累加和,这样每个新矩形可以由上一个矩形减一排加一排得到。

这些在遍历过程中进行即可


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

int dp[111][111];
int mp[111][111];
int tmp[111][111];

int main()
{
	//fread();
	//fwrite();

	int n,w,h,s,t,x,y;
	while(~scanf("%d",&n) && n)
	{
		scanf("%d%d",&w,&h);
		memset(mp,0,sizeof(mp));

		while(n--)
		{
			scanf("%d%d",&x,&y);
			mp[x][y] = 1;
		}

		scanf("%d%d",&s,&t);
		memset(dp,0,sizeof(dp));
		memset(tmp,0,sizeof(tmp));

		for(int i = 1; i <= w; ++i)
			for(int j = 1; j <= h; ++j)
			{
				//printf("%d %d:\n",i,j);
				x = i < s? 1: i-s+1;
				y = j < t? 1: j-t+1;

				if(j <= t) tmp[i][y] += mp[i][j];
				else tmp[i][y] = tmp[i][y-1]-mp[i][y-1]+mp[i][j];
				
				if(j >= t) 
				{
					if(i <= s) dp[x][y] += tmp[i][y];
					else dp[x][y] = dp[x-1][y]-tmp[x-1][y]+tmp[i][y];
				}

				//printf("dp[%d][%d] = %d\n",x,y,dp[x][y]);
				//printf("tmp[%d][%d] = %d\n",i,y,tmp[i][y]);
			}

		int mx = 0;
		for(int i = 1; i <= w; ++i)
			for(int j = 1; j <= h; ++j)
				mx = max(mx,dp[i][j]);
		printf("%d\n",mx);
	}

	return 0;
}







【POJ 2029】 Get Many Persimmon Trees(DP)

标签:

原文地址:http://blog.csdn.net/challengerrumble/article/details/51162689

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!