码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1060 Leftmost Digit

时间:2014-07-29 14:29:19      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   os   strong   io   for   

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12985    Accepted Submission(s): 4973


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 



解释不好,就不解释了

要了解 log的用法、pow函数的用法



#include<stdio.h>
#include<math.h>
int main()
{
	int T,a;
	double m;
	scanf("%d",&T);
	while(T--)
	{
		__int64 N;
		double a;
		scanf("%I64d",&N);
		m=N*log10((double)N)-(__int64)(N*log10((double)N));
		a=pow(10.0,m);
		printf("%d\n",(int)a);
	}
	return 0;




HDU 1060 Leftmost Digit,布布扣,bubuko.com

HDU 1060 Leftmost Digit

标签:des   style   java   color   os   strong   io   for   

原文地址:http://blog.csdn.net/qq_16767427/article/details/38237177

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!