码迷,mamicode.com
首页 > 其他好文 > 详细

Easier Done Than Said? 【杭电-1039】 附题

时间:2014-07-29 14:39:48      阅读:302      评论:0      收藏:0      [点我收藏+]

标签:acm   杭电   c语言   c   strlen   

 

/*
Easier Done Than Said?
Problem DescriptionPassword security is a tricky thing. Users prefer simple passwords
that are easy to remember (like buddy), but such passwords are often insecure. Some
sites use random computer-generated passwords (like xvtpzyo), but users have a hard
time remembering them and sometimes leave them written on notes stuck to their computer.
One potential solution is to generate "pronounceable" passwords that are relatively secure
 but still easy to remember.
 
FnordCom is developing such a password generator. You work in the quality control department,
 and it‘s your job to test the generator and make sure that the passwords are acceptable. To
 be acceptable, a password must satisfy these three rules:
 
It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters
 are consonants.) Note that these rules are not perfect; there are many common/pronounceable words
  that are not acceptable.
 
InputThe input consists of one or more potential passwords, one per line, followed by a line
containing only the word ‘end‘ that signals the end of the file. Each password is at least one
and at most twenty letters long and consists only of lowercase letters.

OutputFor each password, output whether or not it is acceptable, using the precise format shown
in the example.
Sample Input
a

tv

ptoui

bontres
 
zoggax
 
wiinq
 
eep
 
houctuh
 
end
 
Sample Output
<a> is acceptable.

<tv> is not acceptable.

<ptoui> is not acceptable.
 
<bontres> is not acceptable.

<zoggax> is not acceptable.

<wiinq> is not acceptable.

<eep> is acceptable.
 
<houctuh> is acceptable.
*/
#include<stdio.h>
#include<string.h>
#define N 25
int fun(char p){
 if(p==‘a‘||p==‘e‘||p==‘i‘||p==‘o‘||p==‘u‘)
     return 1;
 return 0;
}
int gun(int a[],int len){
 int i,t;
 int flag=0;
 for(i=0;i<len-2;i++){
  t=a[i]+a[i+1]+a[i+2];
  if((t==0)||(t==3)){
   flag=1;
   break;
  }
 }
 return flag;
}

int hun(char s[]){
 int i,len;
 int flag=0;
 len=strlen(s);
 
    for(i=0;i<len-1;i++){
       if((s[i]==s[i+1])&&((s[i]!=‘e‘)&&(s[i]!=‘o‘))){
        flag=1;
        break;
       }
    }
    return flag;
}

int main(){
 char str[N]={0};
 scanf("%s",str);
 while(strcmp(str,"end")){
 int count=0;
 int a[20]={0};
 int len=0;
 len=strlen(str);
 //while(scanf("%s",str),str!="end"){
 
  for(int i=0;i<len;i++){
   
            if(fun(str[i])){
                 a[i]=1;
                 if(!count)  count=1;
            }
            else       a[i]=0; 
           
        }

       if(!count)        printf("<%s> is not acceptable.\n",str);
    else if(gun(a,len))
                      printf("<%s> is not acceptable.\n",str);
      
    else if(hun(str))
                     printf("<%s> is not acceptable.\n",str);
   
       else               printf("<%s> is acceptable.\n",str); 
     scanf("%s",str);
 }
 return 0;
}

Easier Done Than Said? 【杭电-1039】 附题,布布扣,bubuko.com

Easier Done Than Said? 【杭电-1039】 附题

标签:acm   杭电   c语言   c   strlen   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/38236117

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!