码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2057

时间:2014-07-29 14:43:18      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:杭电   计算机   16进制   

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14940    Accepted Submission(s): 6509


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

Sample Output
0 2C 11 -2C -90
 

Author
linle
 

Source
 
 
计算机能够处理16进制数
代码如下;
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int main()
{
 __int64 a,b;
 while(~scanf("%I64X%I64X",&a,&b))
 {
  if(a+b<0)
  printf("-%I64X\n",-a-b);
  else
  printf("%I64X\n",a+b);
 }
 return 0;
}

杭电 2057,布布扣,bubuko.com

杭电 2057

标签:杭电   计算机   16进制   

原文地址:http://blog.csdn.net/ice_alone/article/details/38235763

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!