码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 4681

时间:2014-07-29 15:00:18      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:杭电   printf   费马小定理   

Couple doubi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 743    Accepted Submission(s): 537


Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input
Multiply Test Cases.
In the first line there are two Integers k and p(1<k,p<2^31).
 

Output
For each line, output an integer, as described above.
 

Sample Input
2 3 20 3
 

Sample Output
YES NO
 

Author
FZU
 

Source
 
费马小定理 最终只需要判定k/(p-1)是否是奇数就行了
代码如下
#include<stdio.h>
int main()
{
 int p,k,m;
 while(~scanf("%d%d",&k,&p))
 {
  m=k/(p-1);
  if(m&1)//if(m%2==1)
  printf("YES\n");
  else
  printf("NO\n");
 }
 return 0;
}

杭电 4681,布布扣,bubuko.com

杭电 4681

标签:杭电   printf   费马小定理   

原文地址:http://blog.csdn.net/ice_alone/article/details/38233075

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!