码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 搜索练习 Prime Ring Problem

时间:2016-04-17 20:52:03      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 17 Accepted Submission(s) : 10
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.<br><br>Note: the number of first circle should always be 1.<br><br><img src=../../data/images/1016-1.gif><br>
 技术分享

技术分享

Input技术分享技术分享技术分享技术分享
n (0 < n < 20).<br>
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.<br><br>You are to write a program that completes above process.<br><br>Print a blank line after each case.<br>
 

 

Sample Input
6
8
 

 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
 
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
简单题意:
  就是判断连续两个数字之和为素数,
 
思路分析: 
  直接dfs, 没有目标
 
# include <iostream>
# include <cstring>
# include <fstream>
using namespace std;
int n;
int is[30], a[30];
bool Is(int x)
{
    for(int i = 2; i * i <= x; i++)
        if(x % i == 0)
            return false;
    return true;
}
void dfs(int , int );
int main()
{
    int k = 0;
    // fstream cin("aaa.txt");
    while(cin >> n)
    {
        memset(is, 0, sizeof(is));
        k++;
        cout << "Case " << k << ":" << endl;
        is[1] = 1;
        a[1] = 1;
        dfs(1, 2);
        cout << endl;
    }

    return 0;
}
void dfs(int x, int y)
{
    for(int i = 2; i <= n; i++)
    {
        if(!is[i] && Is(x + i))
        {
            is[i] = 1;
            a[y] = i;
            dfs(i, y + 1);
            is[i] = 0;
        }
    }
    if((y == n + 1) && Is(x + 1))
    {
        for(int i = 1; i < n; i++)
            cout << a[i] << " ";
        cout << a[n] << endl;
    }
}

 

HDU 搜索练习 Prime Ring Problem

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5401991.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!