码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 1060

时间:2014-07-29 15:04:40      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:杭电

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12947    Accepted Submission(s): 4953


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
 
 
 
Ignatius.L
 
 
一看题上的 数值范围 就知道一般的数值类型没法表示 考虑到__int64
又因为n^n数值太大 考虑用指数表示法
 则有n^n=a*10^x;
等号两边对10取对数得 n*log10n=lga+x;
则lga=(n*lgn-x)
x可以通过对n*lgn向下取整求得
则有lga=(n*lgn-[n*lgn])
所以有以下代码:
#include<stdio.h>
#include<math.h>
int main()
{
 int t;
 scanf("%d",&t);
 while(t--)
 {
  __int64 n,s;
  double m;
  scanf("%I64d",&n);
  m=n*log10(n+0.0);
  m-=(__int64)m;
  s=(__int64)pow(10,m);
  printf("%I64d\n",s);
 }
 return 0;
}

杭电 1060,布布扣,bubuko.com

杭电 1060

标签:杭电

原文地址:http://blog.csdn.net/ice_alone/article/details/38232329

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!