码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2095 find your present(2)

时间:2014-07-29 15:09:18      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:acm   二进制   

find your present (2)

Time Limit: 1000/2000 MS (Java/Others) Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 5186 Accepted Submission(s): 1513
 
Problem Description
In the new year party, everybody will get a "special present".Now it‘s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present‘s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 
Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 
Output
For each case, output an integer in a line, which is the card number of your present.
 
Sample Input
5
1 1 3 2 2
3
1 2 1
0
 
Sample Output
3
2

Hint
Hint
use scanf to avoid Time Limit Exceeded
 
真坑。。。题目给的数据量过大开数组会   Memory Limit Exceeded  只能用异或
整数的异或是先把它们化成二进制,再按位异或。
比如3^5,3=011,5=101,两数按位异或后为110,即6。
几个数异或满足交换律。2^3^2=2^2^3=0^3=3.
两个相同的数异或为0,普通数都出现了偶数次,
所以它们异或后都是0,而0与那个特别数异或后还是那个特殊数。



#include<stdio.h>
int main()
{
    int n,i,x,y;
    while(scanf("%d",&n)!=EOF&&n)
    {
           x=0;
           while(n--)
           {
                scanf("%d",&y);
                x^=y;     
           }         
           printf("%d\n",x);             
    }
    return 0;
}


hdu 2095 find your present(2),布布扣,bubuko.com

hdu 2095 find your present(2)

标签:acm   二进制   

原文地址:http://blog.csdn.net/fanerxiaoqinnian/article/details/38231589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!