码迷,mamicode.com
首页 > 其他好文 > 详细

Oil Deposits

时间:2016-04-18 22:20:43      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. <br>
 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.<br>
 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.<br>
 

样例输入:

 1 1

*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

样例输出: 

0
1
2
2

题意:@代表石油,@的八个方位如果存在@,则@看成共属于一个油块,求油块的个数。
思路:典型的深搜,编写一个深搜算法ok

代码:

#include <iostream>
#include<string.h>
using namespace std;
//定义点的八个方向
int dir[8][2] = {{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}};

bool vis[105][105];
char map[105][105];

int m = 0,n = 0;

bool isok(int x,int y){

  //注意这边是x >= 0,y >= 0不要写成x > 0,y > 0

  if(x >= 0 && x < m && y >= 0 && y < n && map[x][y]==‘@‘){
    return true;
  }
  else{
    return false;
  }
}

void dfs(int x ,int y){
  int dx,dy;
  for(int i = 0;i < 8;i++){
    dx = dir[i][0] + x;
    dy = dir[i][1] + y;
    if(isok(dx,dy) && !vis[dx][dy]){
      vis[dx][dy] = true;
      dfs(dx,dy);
    }
  }
}

int main()
{
  int i = 0,j = 0;
  while(cin >> m >> n){
    if(m == 0 && n == 0){
      break;
    }
    for(i = 0;i < m;i ++)
    for(j = 0;j < n;j ++){
      cin >> map[i][j];
    }
    int cnt = 0;
    memset(vis,0,sizeof(vis));
    for(i = 0;i < m;i ++)
    for(j = 0;j < n;j ++){
      if(map[i][j] == ‘@‘ && !vis[i][j]){
        cnt ++ ;
       dfs(i,j);
      }
    }
    cout << cnt << endl;
   }

  return 0;
}



Oil Deposits

标签:

原文地址:http://www.cnblogs.com/2016zhanggang/p/5406069.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!