码迷,mamicode.com
首页 > 其他好文 > 详细

uva539 The Settlers of Catan

时间:2014-07-29 16:57:12      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   for   

The Settlers of Catan

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game‘s special rules:

When the game ends, the player who built the longest road gains two extra victory points.

The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).

Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn‘t use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      o        o -- o        o -- o
               \      /
                o -- o

Input

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( bubuko.com,布布扣) and the number of edges m ( bubuko.com,布布扣). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2
12

 

// 题意:输入n个结点和m条边的无向图(不一定连通),求最长路的长度。边不能经过两次,但是顶点可以重复经过
// 限制:2<=n<=25, 1<=m<=25,没有自环和重边
// 算法:DFS

 

dfs中更新深度d

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=26;
int a[maxn][maxn];
int n, m;
int ans;

void dfs(int i, int d)
{
    for(int j=0; j<n; j++) if(a[i][j]) {
        a[i][j]=0;
        a[j][i]=0;
        dfs(j, d+1);
        a[i][j]=1;
        a[j][i]=1;
    }
    ans=max(ans, d);
}

int solve()
{
    ans=0;
    for(int i=0;i<n;i++)
        dfs(i, 0);
    return ans;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("./uva539.in", "r", stdin);
#endif
    while(scanf("%d%d", &n, &m)==2 && (n || m)) {
        memset(a, 0, sizeof(a));
        for(int i=0;i<m;i++) {
            int x,y;
            scanf("%d%d", &x, &y);
            a[x][y]=1;
            a[y][x]=1;
        }
        printf("%d\n", solve());
    }

    return 0;
}

dfs求长度另一种写法: dfs返回最长长度

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=26;
int G[maxn][maxn];
int n, m;

int dfs(int i)
{
    int len=0;
    for(int j=0; j<n; j++) if(G[i][j]) {
        G[i][j]=G[j][i]=0;
        len=max(len, dfs(j)+1);
        G[i][j]=G[j][i]=1;
    }
    return len;
}

int solve()
{
    int ans=0;
    for(int i=0;i<n;i++)
        ans=max(ans, dfs(i));
    return ans;
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("./uva539.in", "r", stdin);
#endif
    while(scanf("%d%d", &n, &m)==2 && (n || m)) {
        memset(G, 0, sizeof(G));
        for(int i=0;i<m;i++) {
            int x,y;
            scanf("%d%d", &x, &y); G[x][y]=G[y][x]=1;
        }
        printf("%d\n", solve());
    }
    return 0;
}

uva539 The Settlers of Catan,布布扣,bubuko.com

uva539 The Settlers of Catan

标签:des   style   blog   http   color   os   io   for   

原文地址:http://www.cnblogs.com/cute/p/3875504.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!