码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1009 FatMouse' Trade 【贪心】

时间:2014-07-29 17:47:52      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:hdu1009

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42786    Accepted Submission(s): 14274


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 


 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 


 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 


 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 


 

Sample Output
13.333 31.500

题意:给定一个容量为m的背包以及n个物品和每个物品的重量及价值,单个物品可以任意切分,求背包能获得的最大装载价值。

题解:可以求出每个物品的单位重量价值,排序,每次选择单位价值最大的装包即可。

 

#include <stdio.h>
#include <algorithm>
#define maxn 1002
using std::sort;

struct Node{
	int v, c;
	double val;
} arr[maxn];

bool cmp(Node a, Node b)
{
	return a.val > b.val;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);
	int m, n, i, a, b;
	double ans;
	while(scanf("%d%d", &m, &n), m >= 0 && n >= 0){
		for(i = 0; i < n; ++i){
			scanf("%d%d", &a, &b);
			arr[i].val = a * 1.0 / b;
			arr[i].v = a; arr[i].c = b;
		}
		ans = 0;
		sort(arr, arr + n, cmp);
		for(i = 0; i < n; ++i){
			if(m >= arr[i].c){
				m -= arr[i].c; ans += arr[i].v;
			}else{
				ans += m * arr[i].val; break;
			}
		}
		printf("%.3lf\n", ans);
	}
	return 0;
}


 

HDU1009 FatMouse' Trade 【贪心】,布布扣,bubuko.com

HDU1009 FatMouse' Trade 【贪心】

标签:hdu1009

原文地址:http://blog.csdn.net/chang_mu/article/details/38273735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!