码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2503

时间:2014-07-29 17:52:02      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:杭电

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10590    Accepted Submission(s): 6446


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
1 5
 

Sample Output
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL
 

Source
 
将步骤写出来自己观察 发现 这道题的意思是看输入的那个数
除了1之外的是否有其他的因子,要是有的话就计算因子的总数
要是总数为奇数的话说明最终加上1的那次偏转 共有偶数次偏转
开始的时候的为0即:
除一外 有奇数个因子的数或者是1的数 最终结果输出1
为偶数 的最终输出结果为零
代码如下:
#include<stdio.h>
int prime(int n)
{
 int count=0,i;
 if(n==1)
 return 1;
 for(i=2;i<=n/2;i++)
 {
  if(n%i==0)
  count++;
 }
 return count;
}
int main()
{
 int n;
 while(~scanf("%d",&n))
 {
  if(prime(n)&1)
  printf("1\n");
  else
  printf("0\n");
 }
 return 0;
}

杭电 2503,布布扣,bubuko.com

杭电 2503

标签:杭电

原文地址:http://blog.csdn.net/ice_alone/article/details/38272919

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!