码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1162 Eddy's picture 【最小生成树Prim】

时间:2014-07-29 17:59:42      阅读:304      评论:0      收藏:0      [点我收藏+]

标签:hdu1162

Eddy‘s picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6723    Accepted Submission(s): 3391


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 


 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 


 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 


 

Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 


 

Sample Output
3.41

题意:给定n个点的坐标,求将这n个点连起来的最小生成树。

题解:直接套模板。

 

#include <stdio.h>
#include <math.h>
#include <string.h>
#define maxn 102

double _x[maxn], _y[maxn];
double map[maxn][maxn];
bool vis[maxn];

double cal(int i, int j)
{
	double x = _x[i] - _x[j];
	double y = _y[i] - _y[j];
	return sqrt(x * x + y * y);
}

void Prim(int n)
{
	int i, j, count = 0, u;
	double len = 0, tmp;
	vis[0] = 1;
	while(count < n - 1){
		for(i = 0, tmp = -1; i < n; ++i){
			if(!vis[i]) continue;
			for(j = 0; j < n; ++j)
				if(!vis[j] && (map[i][j] < tmp || tmp < 0)){
					tmp = map[i][j]; u = j;
				}
		}
		if(tmp >= 0){
			++count; vis[u] = 1;
			len += tmp;
		}
	}
	printf("%.2lf\n", len);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);
	int n, i, j;
	double len;
	while(scanf("%d", &n) != EOF){
		memset(vis, 0, sizeof(vis));
		for(i = 0; i < n; ++i){
			scanf("%lf%lf", _x + i, _y + i);
			for(j = 0; j < i; ++j){
				len = cal(i, j);
				map[i][j] = map[j][i] = len;
			}
		}
		Prim(n);
	}
	return 0;
}


 

HDU1162 Eddy's picture 【最小生成树Prim】,布布扣,bubuko.com

HDU1162 Eddy's picture 【最小生成树Prim】

标签:hdu1162

原文地址:http://blog.csdn.net/chang_mu/article/details/38271711

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!