码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1875 畅通工程再续 【最小生成树Prim】

时间:2014-07-29 18:04:23      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:hdu1875

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14590    Accepted Submission(s): 4497


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 


 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 


 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 


 

Sample Input
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 


 

Sample Output
1414.2 oh!

 

这题的陷阱是注意浮点数。
#include <stdio.h>
#include <string.h>
#include <math.h>
#define maxn 102

double map[maxn][maxn];
bool vis[maxn];
struct Node{
    int x, y;
} arr[maxn];

double cal(Node a, Node b)
{
    double x = a.x - b.x, y = a.y - b.y;
    return sqrt(x * x + y * y);
}

void Prim(int n)
{
    int u, i, j, count = 0;
    double len = 0, tmp;
    vis[0] = 1;
    while(count < n - 1){
        for(i = 0, tmp = -1; i < n; ++i){
            if(!vis[i]) continue;
            for(j = 0; j < n; ++j){
                if(map[i][j] >= 0 && !vis[j] && (map[i][j] < tmp || tmp < 0)){
                    tmp = map[i][j]; u = j;
                }
            }
        }
        if(tmp > 0){
            ++count; vis[u] = 1;
            len += tmp * 100;
        }else break;
    }
    if(count == n - 1) printf("%.1lf\n", len);
    else printf("oh!\n");
}

int main()
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int t, n, a, b, i, j;
    double len;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        memset(vis, 0, sizeof(vis));
        for(i = 0; i <= n; ++i)
            for(j = 0; j <= n; ++j) map[i][j] = -1;
        for(i = 0; i < n; ++i){
            scanf("%d%d", &arr[i].x, &arr[i].y);
            for(j = 0; j < i; ++j){
                len = cal(arr[i], arr[j]);
                if(len >= 10.0 && len <= 1000.0){
                    if(map[i][j] < 0 || len < map[i][j])
                        map[i][j] = map[j][i] = len;
                }
            }
        }
        Prim(n);
    }
    return 0;
}


 

HDU1875 畅通工程再续 【最小生成树Prim】,布布扣,bubuko.com

HDU1875 畅通工程再续 【最小生成树Prim】

标签:hdu1875

原文地址:http://blog.csdn.net/chang_mu/article/details/38270851

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!