码迷,mamicode.com
首页 > 其他好文 > 详细

大数阶乘

时间:2014-07-29 18:06:02      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   数据   

A - N!
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! 
 

Input

One N in one line, process to the end of file. 
 

Output

For each N, output N! in one line. 
 

Sample Input

1 2 3
 

Sample Output

1 2 6
 数组模拟
我跑了一个10000的数据,显示超时根本算不出来,可提交竟然对了,10000!真是个天文数字。
#include<stdio.h>
#include<string.h>
int main(){
	int a[101000],n,l;
	while(~scanf("%d",&n)){
		memset(a,0,sizeof(a));
		a[0] =1;
		l=1;
		for(int i=1;i<=n;i++){
			int s = 0,j;
			for( j=0;j<l||s;j++){
				  int z= a[j]*i+s;
					a[j] = z%10;
					s = z/10;
			}
			l=j;
			//printf("%d\n",l);
		}
		for(int j = l-1;j>=0;j--)printf("%d",a[j]);
		printf("\n");
	}
} 


大数阶乘,布布扣,bubuko.com

大数阶乘

标签:des   style   http   color   os   strong   io   数据   

原文地址:http://blog.csdn.net/yuanhanchun/article/details/38270651

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!