码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 5665 Lucky (技巧)

时间:2016-04-22 20:55:10      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:

HDU - 5665
Time Limit: 1000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

技术分享技术分享技术分享技术分享Chaos August likes to study the lucky numbers. 

技术分享技术分享技术分享技术分享For a set of numbers S,we set the minimum non-negative integer,which can‘t be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times. 

技术分享技术分享技术分享技术分享Now, given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".
 

Input

技术分享技术分享技术分享技术分享The first line is a number T,which is case number. 

技术分享技术分享技术分享技术分享In each case,the first line is a number n,which is the size of the number set. 

技术分享技术分享技术分享技术分享Next are n numbers,means the number in the number set. 

技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享技术分享.
 

Output

技术分享技术分享技术分享技术分享Output“YES”or “NO”to every query.
 

Sample Input

1 1 2
 

Sample Output

NO
 

Source

BestCoder Round #80
//题意:
给你n个数,问你用这些数相加,是否可以得到最小的非负整数(0和1)?
//思路:
只用判断给的数中是否有0和1就行了,只有一个也是不行的
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ll long long
#define N 1010
#define M 1000000007
using namespace std; 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		bool f1=false,f2=false;
		for(int i=0;i<n;i++)
		{
			int a;
			scanf("%d",&a);
			if(a==1)
				f1=true;
			if(a==0)
				f2=true;
		}
		if(f1&&f2) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

HDU - 5665 Lucky (技巧)

标签:

原文地址:http://blog.csdn.net/yanghui07216/article/details/51200289

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!