码迷,mamicode.com
首页 > 其他好文 > 详细

Red and Black

时间:2016-04-22 23:41:28      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
45
59
6
13
 
题意:输出行数列数,@为起始位置,#不可通行,.可以通行,统计可以走的.
本题为典型的深搜,比这葫芦画瓢就行了。
代码:

#include <iostream>
#include <string.h>
#include<stdio.h>
using namespace std;
char map[50][50];
bool vis[50][50];//记录访问点
int h,w;
int cnt;
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};

bool ok(int x,int y){
  if(x >= 0 && x < h && y >= 0 && y < w && map[x][y] == ‘.‘){
    return true;
  }
  else{
    return false;
  }
}
void dfs(int x,int y){
  cnt ++;
  vis[x][y] = true;
  int i;
  for(i = 0;i < 4;i++){
    int x1 = x + dir[i][0];//一定注意是从零开始,我就是从一开始的,最终浪费了很大的功夫检查,到最后才发现出现在这个地方。
    int y1 = y + dir[i][1];
    if(!vis[x1][y1] && ok(x1,y1)){
      dfs(x1,y1);
    }
  }
  return;
}

int main()
{
  int x = 0,y = 0;
  int i,j;
  while(cin >> w >> h){
    if(w == 0 && h == 0){
      break;
    }
    getchar();
    memset(vis,false,sizeof(vis));
    for(i = 0;i < h;i ++){
      for(j = 0;j < w;j++){
        cin >> map[i][j];
        if(map[i][j] == ‘@‘){
          x = i;
          y = j;
        }
      }
    }
    getchar();
    cnt = 0;
    dfs(x,y);
    cout << cnt << endl;
  }

  return 0;
}
/*
....#.
.....#
......
......
......
......
......
#@...#
.#..#.

*/

 

 

Red and Black

标签:

原文地址:http://www.cnblogs.com/2016zhanggang/p/5423051.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!