码迷,mamicode.com
首页 > 其他好文 > 详细

hdu-5673 Robot(默次金数)

时间:2016-04-22 23:51:12      阅读:272      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:

Robot

Time Limit: 12000/6000 MS (Java/Others)
 Memory Limit: 65536/65536 K (Java/Others)
问题描述
有一个机器人位于坐标原点上。每秒钟机器人都可以向右移到一个单位距离,或者在原地不动。如果机器人的当前位置在原点右侧,它同样可以
向左移动单位距离。一系列的移动(左移,右移,原地不动)定义为一个路径。问有多少种不同的路径,使得nn秒后机器人仍然位于坐标原点?
答案可能很大,只需输出答案对1,000,000,0071,000,000,007的模。
输入描述
输入包含多组数据. 第一行有一个整数T (1\leq T\leq 100)T(1T100), 表示测试数据的组数. 对于每组数据:
输入一个整数 n (1\leq n\leq 1,000,000)n(1n1,000,000)。
输出描述
对于每组数据,输出一个整数
输入样例
3
1
2
4
输出样例
1
2
9

思路:

比赛的时候一直推不出公式,还是得好好补补组合数学;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
const ll mod=1e9+7;
const int N=1e6+6;
ll dp[N];

ll fastpow(ll a,ll b)
{
    ll ans=1,base=a;
    while(b)
    {
        if(b&1)
        {
            ans=ans*base;
            ans%=mod;
        }
        base*=base;
        base%=mod;
        b=(b>>1);
    }
    return ans;
}
void fun()
{
    dp[1]=1;
    dp[2]=2;
    for(int i=3;i<N;i++)
    {
        ll x=(ll)(i+3);
        ll y=(ll)(2*i+1);
        ll z=(ll)(3*i-3);
        dp[i]=(y*dp[i-1]%mod+z*dp[i-2]%mod)*fastpow((ll)(i+2),mod-2)%mod;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    fun();
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%I64d\n",dp[n]);
    }

    return 0;
}

 

hdu-5673 Robot(默次金数)

标签:

原文地址:http://www.cnblogs.com/zhangchengc919/p/5423114.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!