码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1114 完全背包

时间:2016-04-23 18:24:38      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19077    Accepted Submission(s): 9665


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
 

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams.
 

 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
题目大意:对于一个储钱猪,你不知道里面有多少钱,你只能通过猪的体重和相应硬币的重量来进行估算,让你输出这个猪里面的钱最少是多少。
思路分析:稍加思考就知道这是一个背包问题,同时题目并没有限制每一种硬币的数目,即所有硬币都是无穷多的,因此应该套用完全背包模板,但是在
初始化的时候要注意,因为猪的重量是明确给出的,即背包必须要恰好装满,同时区别于模板背包问题,这相当于是让你输出最少价值,f[0]=0,其他初始化为正无穷
所以在状态转移的时候把max,变成min即可,1A而过。
代码:
#include <iostream>
#include <stack>
#include <cstdio>
#include <cstring>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn1=10000+100;
const int maxn2=500+50;
int f[maxn1];
int v[maxn2],w[maxn2];
const int inf=99999999;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int E,F,V,N;
        scanf("%d%d",&E,&F);
        scanf("%d",&N);
        V=F-E;
        for(int i=1;i<=N;i++)
            scanf("%d%d",&v[i],&w[i]);
        f[0]=0;
        for(int i=1;i<=V;i++)
            f[i]=inf;
        for(int i=1;i<=N;i++)
        {
            for(int j=w[i];j<=V;j++)
            {
                f[j]=min(f[j],f[j-w[i]]+v[i]);
            }
        }
       if(f[V]<inf)
           printf("The minimum amount of money in the piggy-bank is %d.\n",f[V]);
        else printf("This is impossible.\n");
    }
}

hdu1114 完全背包

标签:

原文地址:http://www.cnblogs.com/xuejianye/p/5425079.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!