码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1004 查气球

时间:2016-04-23 19:58:15      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 102132    Accepted Submission(s): 39192


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink
 

 

Author
WU, Jiazhi
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1019 1021 1013 1012 
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <stdio.h>
using namespace std;
int main()
{
    int i,j,n,t;
    while (cin>>n&&n)
    {
        char c[1005][20];
        int a[1005];
        memset(a,0,sizeof(a));
        for (i=0;i<n;i++)
        {
            cin>>c[i];
            for (j=0;j<i;j++)
            {
                if (strcmp(c[i],c[j])==0)
                a[i]++;
            }
        }
        int max=0,t=0;
        for (i=0;i<n;i++)
        {
            if (a[i]>max)
            {
                max=a[i];
                t=i;
            }
        }
        cout<<c[t]<<endl;

    }



    return 0;
}

 

HDU1004 查气球

标签:

原文地址:http://www.cnblogs.com/Ritchie/p/5425308.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!