码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1297女孩不能单独走 (DP)

时间:2016-04-23 21:06:43      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13333    Accepted Submission(s): 4364


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 2 4
 

 

Author
SmallBeer (CML)
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2044 2045 2050 2046 1290 

a[i-1]:合法+男
a[i-2}:合法+女女
a[i-4}:合法+男女(即不合法)+女女


这是三种没有互相交叉的不同情况!


解释:
设:F(n)表示n个人的合法队列,则:

按照最后一个人的性别分析,他要么是男,要么是女,
所以可以分两大类讨论:

1、如果n个人的合法队列的最后一个人是男,
则前面n-1个人组成的队列只要是合法的队列即可,
最后一个男生只 需要站在最后即可,所以,这种情况一共有F(n-1);

2、如果n个人的合法队列的最后一个人是女,
则要求队列的第n-1个人务必也是女生,这就是说,
限定了最后两个 人必须都是女生,这又可以分两种情况:

2.1、如果队列的前n-2个人是合法的队列,
则显然后面再加两个女生,也一定是合法的,这种情况有F(n-2);
2.2、但是,即使前面n-2个人不是合法的队列,加上两个女生也有可能是合法的,
当然,这种长度为n-2的不合法 队列,不合法的地方必须是尾巴,
就是说,这里说的长度是n-2的不合法串的形式必须是F(n-4)+男+女,
这种情况一共有F(n-4).
Source

HDU1297

思路如下:

一个长度n的队列可以看成一个n - 1的队列再追加的1个小孩,这个小孩只可能是:

a.男孩,任何n - 1的合法队列追加1个男孩必然是合法的,情况数为f[n - 1];

b.女孩,在前n - 1的以女孩为末尾的队列后追加1位女孩也是合法的,我们可以转化为n - 2的队列中追加2位女孩;

一种情况是在n - 2的合法队列中追加2位女孩,情况数为f[n - 2];

但我们注意到本题的难点,可能前n - 2位以女孩为末尾的不合法队列(即单纯以1位女孩结尾),
也可以追加2位女孩成为合法队列,而这种n - 2不合法队列必然是由n - 4合法队列+1男孩+1女孩的结构,
即情况数为f[n - 4]。


若感觉本题较难,可先查看文章:[ACM_HDU_2045]LELE的RPG难题,思路与本题类似,但较为简单。
得出递推公式如下:
a[i]=a[i-1]+a[i-2]+a[i-4];

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
using namespace std;
long long  a[10005][110]={0};
int main()
{
    int i,j,n;
    a[1][0]=1;
    a[2][0]=2;
    a[3][0]=4;
    a[4][0]=7;
    a[5][0]=12;
    for(i=6;i<=1000;i++)
    {
        for(j=0;j<=105;j++)
        {
            a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-4][j];
            a[i][j+1]+=a[i][j]/100000000;
            a[i][j]%=100000000;
        }
    }
    while(cin>>n)
    {
        for(j=105;j>=0;j--)
        if(a[n][j]!=0)
        break;
        cout<<a[n][j];
        for(j=j-1;j>=0;j--)
        printf("%08d",a[n][j]); //不能直接cout 数大的时候是错的
        cout<<endl;
    }
    return 0;
}

 

HDU1297女孩不能单独走 (DP)

标签:

原文地址:http://www.cnblogs.com/Ritchie/p/5425339.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!