码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 1029 Ignatius and the Princess IV

时间:2014-07-29 21:58:22      阅读:352      评论:0      收藏:0      [点我收藏+]

标签:杭电   dp   

http://acm.hdu.edu.cn/showproblem.php?pid=1029

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 16754    Accepted Submission(s): 6730

Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
3 5 1
 

这个问题就等于求出现次数最多的那一个数,但是题目给的数据太大了,这样做下去肯定超时,注意看清题意,题目已经说了输入是奇数个数(n),一定会有一个数出现的次数至少为(n+1)/2;这样题目就变简单了好多,直接排序之后输出中间那个数,一定为所求,这个就很容易理解啦啦bubuko.com,布布扣
AC代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int a[1000000];

int main()
{
    int n,i,j,k;
    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        printf("%d\n",a[(n+1)/2]);
    }
    return 0;
}


杭电 1029 Ignatius and the Princess IV,布布扣,bubuko.com

杭电 1029 Ignatius and the Princess IV

标签:杭电   dp   

原文地址:http://blog.csdn.net/u012766950/article/details/38276919

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!