码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2367 topological_sort

时间:2014-07-29 22:10:42      阅读:533      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   2014   art   ar   

Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2920 Accepted: 1962 Special Judge
Description

The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output

The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output

2 4 5 3 1
Source

Ural State University Internal Contest October‘2000 Junior Session
 
/**********************************************

      author   :    Grant Yuan
      time     :    2014.7.29
      algorithm:    topological_sort
      source   :    POJ 2367

**********************************************/

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 101
using namespace std;

int mat[MAX][MAX],num[MAX];
int n,m,ans,sum;
int lu[MAX];

int main()
{   int a,b;
    while(~scanf("%d",&n)){
        memset(mat,0,sizeof(mat));
        memset(num,0,sizeof(num));
        memset(lu,0,sizeof(lu));
        for(int i=1;i<=n;i++)
        {

           while(1){
            scanf("%d",&a);
           if(a==0) break;
           if(mat[i][a]==0)
           {
               mat[i][a]=1;
               num[i]++;
           }
        }}
        int i,p=n;
        while(1){
            for(i=n;i>0;i--)
            {
                if(num[i]==0)
                    break;
            }
            if(i==0)
                break;
                num[i]=-1;

            lu[p--]=i;
            for(int j=1;j<=n;j++)
            {
                if(mat[j][i])
                    num[j]--;
            }
        }

        for(int j=1;j<=n;j++)
            if(j<n)printf("%d ",lu[j]);
            else printf("%d",lu[j]);
        printf("\n");
    }
    return 0;
}

POJ 2367 topological_sort,布布扣,bubuko.com

POJ 2367 topological_sort

标签:des   style   os   io   for   2014   art   ar   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/38274785

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!