码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1062 Text Reverse

时间:2014-07-30 00:24:12      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   os   strong   io   

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16428    Accepted Submission(s): 6237

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

 

Output
For each test case, you should output the text which is processed.
 

 

Sample Input
3
olleh !dlrow
m‘I morf .udh
I ekil .mca
 

 

Sample Output
hello world!
I‘m from hdu.
I like acm.

 

 

 

 

 

#include <iostream>

using namespace std;

int main()

{

           int n;  

                     cin>>n;  

                    getchar();

                    while(n--)  

   {  

             char a[1005];

                       gets(a);   

                   int i,j,k;  

            for(i=0;i<strlen(a);i++)   

         {   

                  if(a[i]!=‘ ‘)    

                     {     for(j=i;a[j]!=‘ ‘&&j<strlen(a);j++);   

                             for(k=j-1;k>=i;k--)                 cout<<a[k];

                                         i=j-1;       

                            }    

                                    else cout<<" ";   

             }   

                    cout<<endl;     

 

 return 0;

}

 

hdu 1062 Text Reverse,布布扣,bubuko.com

hdu 1062 Text Reverse

标签:des   style   http   java   color   os   strong   io   

原文地址:http://www.cnblogs.com/2014acm/p/3876536.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!