码迷,mamicode.com
首页 > 其他好文 > 详细

HUD 动态规划 A

时间:2016-04-26 10:57:34      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:

Problem A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 206947    Accepted Submission(s): 48397


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4
Case 2: 7 1 6
 
简单题意:
  求最大子段和,,并记录位置。。。
简单思路:
  第一个DP,写的比较艰难,,,,用从第一个开始求最大子段和,再判断下一个数的最大子段和
 
#include <iostream>
#include <fstream>
#include <cstdio>
using namespace std;

int main()
{
    //fstream cin("aaa.txt");
    int t, jishu = 1;
    cin >> t;
    while (t--)
    {

        int n, dp = 0, max = -1000001, r = 1, l = 1, temp = 1;
        cin >> n;
        for(int i = 1; i <= n; i++)
        {
            int tep;
            cin >> tep;
            dp += tep;
            if (dp > max)
            {
                max = dp;
                r = temp;
                l = i;
            }
            if (dp < 0)
            {
                dp = 0;
                temp = i + 1;
            }
        }
        printf("Case %d:\n%d %d %d\n", jishu++, max, r, l);
        if (t != 0)
            cout << endl;
    }
    return 0;
}

 

HUD 动态规划 A

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5433991.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!