码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 动态规划 B

时间:2016-04-26 10:58:03      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Problem B

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 9
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 

 

Sample Output
4 2 0
 
简单题意:
  求两个字符串的最大公共子序列,,
 
思路分析:
  先求一个字符,,再推下一个,,如果一个字符一样 则dp[i][j] = dp[i - 1][j - 1] + 1;
  否则此地为 dp[i][j] = MAX(dp[i - 1][j], dp[i][j-1]);
  状态方程如上面
#include <iostream>
#include <fstream>
#include <string>
#include <cstring>
using namespace std;
const int MAX = 1111;
int dp[MAX][MAX];
int f(int x, int y)
{
    if(x > y)
    return x;
    return y;
}

int main()
{
    //fstream cin("aaa.txt");
    string a, b;
    while(cin >> a >> b)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= a.size(); i++)
            for(int j = 1; j <= b.size(); j++)
            {
                if(a[i - 1] == b[j - 1])
                    dp[i][j] = dp[i - 1][j - 1] + 1;
                else
                    dp[i][j] = f(dp[i - 1][j], dp[i][j-1]);
            }
        cout << dp[a.size()][b.size()] << endl;
        a = ""; b = "";
    }

    return 0;
}

 

 

HDU 动态规划 B

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5434106.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!