码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1076 An Easy Task

时间:2016-04-26 20:23:09      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19908    Accepted Submission(s): 12725


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
3 2005 25 1855 12 2004 10000
 

Sample Output
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1097 1061 1013 1032 1170 
 

Statistic | Submit | Discuss | Note

Y 开始以后的第N个闰年

闰年为能被4整除不能被100整除 或者被400整除

#include <stdio.h>
int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		int year,n;
		scanf("%d %d",&year,&n);
		for(int i=year;;i++)
		{
			if((i%4==0&&i%100)||i%400==0)
			n--;
			if(n==0)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}


hdu 1076 An Easy Task

标签:

原文地址:http://blog.csdn.net/su20145104009/article/details/51244970

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!