码迷,mamicode.com
首页 > 其他好文 > 详细

Saruman's Army

时间:2016-04-26 23:46:44      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:

第一部分:题目

题目链接:http://poj.org/problem?id=3069

Saruman‘s Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6839   Accepted: 3516

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

第二部分:思路

贪心:1,从小到大排序。从最左边开始,以一个未被包含的点为起点,往后找一个点作为圆心,保证以R为半径的圆必须包含起点。

     2,找与圆心最近但是在圆外的点作为新的起点,接着找圆心。

   3,重复直到最右边。

        4,注意:1,可能存在重复的点,可以排序时去重。(这里使用的是在比较距离时按照距离为整数”去重“)。

                   2,如果最后一个点是新的起点,也就是说要以自己为圆心。

 

第三部分:代码

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n,m;
    int army[1001];
    while(cin>>m>>n,m!=-1&&n!=-1)//当n和m都为-1时结束 
    {
        for(int i=0;i<n;i++)
        {
            cin>>army[i];
        }
        sort(army,army+n);//从小到大排序 
        int count=0;
        //从最左边开始,以一个未被包含的点作为起点,找到尽可能一个远的点
        //作为圆心。但是必须把起点包含进去。找到圆心后,就要找下一个起点。
        //这个起点肯定在圆外。 
        int temp=army[0];
        //flag为1表示找到起点 
        int flag=1;
        for(int i=1;i<n;i++)
        {
            //当起点存在,以当前点作为圆心不能包含起点时,那么前一个点就是圆心 
            if(flag&&army[i]-temp>0&&army[i]-temp>m)
            {
                count++;
                temp=army[i-1];//圆心 
                if(army[i]-temp>m)//当前点不能被圆包含 
                {
                    temp=army[i];//以该点为新的起点 
                }
                else
                {
                    flag=0;//找到圆心后还未找到新的起点 
                    continue; 
                }
            }
            if(flag==0&&army[i]-temp>m)
            {
                temp=army[i];
                flag=1;
            }
        }
        if(flag)//如果flag为1,表示有新的起点,而且这是最后一个点。给它标记 
        {
            count++;
        }
        cout<<count<<endl;
    }
    return 0;
}

 

Saruman's Army

标签:

原文地址:http://www.cnblogs.com/xiangguoguo/p/5436915.html

(1)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!