码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1005 Number Sequence

时间:2016-04-30 12:42:35      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2 5
 
//O(≧口≦)O 这里问需要注意的问题,那就是当时7的倍数的时候,之后的data全都是0,全是0呀!!找不到循环节!!
//(⊙o⊙)… 所以要单独处理一下这个问题;
 
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    int a,b,n,k;
    int data[100];
    data[1]=1;data[2]=1;
    while(cin>>a>>b>>n)
    {
        if(a==0&&b==0&&n==0) break;
        if((a+b)%7==0)
        {
            if(n<3) cout<<"1"<<endl;
            else cout<<"0"<<endl;
        }
        else
        {
            for(int i=3;i<56;i++)
        {
            data[i]=(a*data[i-1]+b*data[i-2])%7;
            if(data[i]==1&&data[i-1]==1)
            {
                data[0]=data[i-2];
                k=i-2;
                break;
            }
        }
        n=n%k;
        cout<<data[n]<<endl;
        }

    }
    return 0;
}

 

hdu 1005 Number Sequence

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5448419.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!