码迷,mamicode.com
首页 > 其他好文 > 详细

ACM 动态规划 D

时间:2016-04-30 12:45:18      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:

Problem D

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13   Accepted Submission(s) : 5
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. <br><br>Write a program to find and print the nth element in this sequence<br>
 

 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.<br>
 

 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.<br>
 

 

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 

 

Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
 
简单题意:
   就是一个数字的因子 只有 2 3 5 7 这几个数字, 求输出啊a[n]
思路分析:
    开始初始化前4个数字,后一个数字肯定是前几个数字的乘积,所以由前几个数字推出后面几个数字的dp方法,,
 
# include <iostream>
# include <vector>
using namespace std;
long long int a[6000];

long long int Min(long long int a, long long int b, long long int c, long long int d)
{
    if(a <= b && a <= c && a <= d) return a;
    if(b <= a && b <= c && b <= d) return b;
    if(c <= b && c <= a && c <= d) return c;
    if(d <= b && d <= c && d <= a) return d;
}

int main()
{
    a[1] = 1; a[2] = 2; a[3] = 3; a[4] = 4;
    int n = 1;
    int num2, num3, num5, num7;
    num2 = num3 = num5 = num7 = 1;
    while(n < 5842)
    {
        n++;
        a[n] = Min(2 * a[num2], 3 * a[num3], 5 * a[num5], 7 * a[num7]);
        if(a[n] == 2 * a[num2])
        num2++;
        if(a[n] == 3 * a[num3])
        num3++;
        if(a[n] == 5 * a[num5])
        num5++;
        if(a[n] == 7 * a[num7])
        num7++;
        //cout << a[n] << endl;
    }
    while(cin >> n)
    {
        if(n == 0)
        break;
        if(n % 10 == 1 && n % 100 != 11)
        cout << "The "<< n << "st humble number is " << a[n] << "." << endl;
        else if(n % 10 == 2 && n % 100 != 12)
        cout << "The "<< n << "nd humble number is " << a[n] << "." << endl;
        else if(n % 10 == 3 && n % 100 != 13)
        cout << "The "<< n << "rd humble number is " << a[n] << "." << endl;
        else
        cout << "The "<< n << "th humble number is " << a[n] << "." << endl;
    }

    return 0;
}

 

 

ACM 动态规划 D

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5448474.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!