码迷,mamicode.com
首页 > 其他好文 > 详细

2016 省赛热身 2016 Programming Ability Test

时间:2016-04-30 22:12:00      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

Programming Ability Test
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
 

Description

Programming Ability Test (PAT) aims to evaluate objectively, through unified examinations with automatic online judging system, the abilities of testees in programming and algorithm design, hence to evaluate scientifically the programming talents, and to provide the enterprises a reference standard for personnel selection.

技术分享

The alliance enterprises may have their specific green channel preferential conditions listed at the PAT registration website. Some enterprises also provide “Letter of Introduction” for the testees to download and submit to the human resource department together with the PAT certificate when seeking employments.

Recently, Edward Co.,LTD joins PAT Alliance and sets their green channel preferential conditions to 80 points of PAT Advanced Level. That means you can enter the green channel if you get 80 points or above on PAT Advanced Level. Now Edward Co.,LTD gets the result of all examinees, please tell them whether the examinee can get the chance of entering green channel.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The only line contains four integers ScoreAScoreBScoreC, and ScoreD - the four problems‘ score of the examinee.(0 <= ScoreA <= 20, 0 <= ScoreBScoreC <= 25, 0 <= ScoreD <= 30)

Output

For each test case, if the examinee gets 80 points or above in total, output "Yes", else output "No".

Sample Input

4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30

Sample Output

No
No
Yes
Yes

水题: 写在这里子想说明,,再难的比赛也有水题。。。
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int a, b, c, d;
        scanf("%d%d%d%d", &a, &b, &c, &d);
        if(a + b + c + d >= 80)
       printf("Yes\n"); else
       printf("No\n"); } return 0; }

 

 

2016 省赛热身 2016 Programming Ability Test

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5449331.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!