码迷,mamicode.com
首页 > 其他好文 > 详细

zoj3827--Beauty of Array (dp)

时间:2016-05-01 17:31:01      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:

Beauty of Array

 


 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 


 

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

 

Input

 

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

 

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

 

Output

 

For each case, print the answer in one line.

 

Sample Input

 

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

 

Sample Output

 

105
21
38

 


Author: LIN, Xi
Source: The 12th Zhejiang Provincial Collegiate Programming Contest

 

dp[i]=dp[i-1]+a*(i-pre[a]);

求相邻数组的总和,其中数组中不能有重复的数字。设dp[i]为以a结尾的长度为(1-->n)的子序列的总和,用pre[a]记录数字a最后出现的位置,以1,2,3,2为例

i=1,a=1

dp[i]=1;

i=2,a=2

dp[i]=2+(1+2);

i=3,a=3

dp[i]=3+(2+3)+(1+2+3);

i=4,a=2,pre[2]=2

dp[i]=2+(3+2)+(2+3+{2})+(1+2+3+{2});

#include <cstdio>
#include <cstring>
#include <iostream>
const int N= 100000+100 ;
typedef long long LL;
using namespace std;
int pre[N]; //去掉重复元素 ; 
LL dp[N];   //dp[i]表示以i结尾的所有(不同长度)子序列的和 ; 
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        memset(pre, 0, sizeof(pre));
        int n; scanf("%d", &n);
        for(int i=1; i<= n; i++)
        {
            int a;
            scanf("%d", &a);
            dp[i]=dp[i-1]+(i-pre[a])*a;
            pre[a]=i;
        }
        LL sum=0;
        for(int i=1; i<= n; i++)
            sum+= dp[i];
        printf("%lld\n", sum);
    }
    return 0;
} 

 

zoj3827--Beauty of Array (dp)

标签:

原文地址:http://www.cnblogs.com/fengshun/p/5450710.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!