码迷,mamicode.com
首页 > 其他好文 > 详细

lightoj - 1414 February 29

时间:2016-05-01 20:26:42      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Status

Description

It is 2012, and it‘s a leap year. So there is a "February 29" in this year, which is called leap day. Interesting thing is the infant who will born in this February 29, will get his/her birthday again in 2016, which is another leap year. So February 29 only exists in leap years. Does leap year comes in every 4 years? Years that are divisible by 4 are leap years, but years that are divisible by 100 are not leap years, unless they are divisible by 400 in which case they are leap years.

In this problem, you will be given two different date. You have to find the number of leap days in between them.

Input

Input starts with an integer T (≤ 550), denoting the number of test cases.

Each of the test cases will have two lines. First line represents the first date and second line represents the second date. Note that, the second date will not represent a date which arrives earlier than the first date. The dates will be in this format - "month day, year", See sample input for exact format. You are guaranteed that dates will be valid and the year will be in between 2 * 103 to 2 * 109. For your convenience, the month list and the number of days per months are given below. You can assume that all the given dates will be a valid date.

Output

For each case, print the case number and the number of leap days in between two given dates (inclusive).

Sample Input

4

January 12, 2012

March 19, 2012

August 12, 2899

August 12, 2901

August 12, 2000

August 12, 2005

February 29, 2004

February 29, 2012

Sample Output

Case 1: 1

Case 2: 0

Case 3: 1

Case 4: 3

Source

Problem Setter: Md. Arifuzzaman Arif
Special Thanks: Jane Alam Jan
 
#include <map> 
#include <cstdio>
#include <iostream>
using namespace std;
map<string,int> mp;
char month[20][25]={"January",  
 "February", "March", "April",  
  "May", "June", "July", "August",  
   "September", "October", "November",  
   "December"};  
bool judge(int y)
{
    if((y%4==0 && y%100 !=0) || y%400 ==0)
        return true;
    return false;
}

int main() 
{
    for(int i=0; i< 12; i++)
        mp[month[i]]= i+1;
        
    int t, Q=1; scanf("%d", &t);
    while(t--)
    {
        char a[25];
        int m, y;
        scanf("%s%d,%d", a, &m, &y);
        int t1=0, t2 =0;
        int bb=mp[a];
        if(judge(y))
        {
            if(bb>2)
                y++;
        }
        y--;
        t1+=y/4-y/100+y/400;
        scanf("%s%d,%d", a, &m, &y);
        if(judge(y))
        {
            if(mp[a]>2|| (mp[a]== 2 && m==29))
                y++;
        }
        y--; 
        t2= t2+y/4-y/100+y/400;
        printf("Case %d: %d\n", Q++, t2-t1);
    }
    return 0;
}

 

lightoj - 1414 February 29

标签:

原文地址:http://www.cnblogs.com/fengshun/p/5451026.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!