码迷,mamicode.com
首页 > 其他好文 > 详细

大数A+B 【杭电-1002】 附题

时间:2014-07-30 17:32:24      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:acm   c语言   strlen   杭电   sizeof   

/*

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209912    Accepted Submission(s): 40404

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

*/

#include<stdio.h>
#include<string.h>
#define N 1000
int main(){
 int n;
  while(~scanf("%d",&n)){
   //吞掉回车符
        getchar();
        int i,j,k,a,b,t;
       //数组定义
          char schar1[N+10]={‘\0‘};
          char schar2[N+10]={‘\0‘};
          int sint1[N+10];
          int sint2[N+10];
       for(k=1;k<=n;k++){
     memset(sint1,0,sizeof(sint1));
                memset(sint2,0,sizeof(sint2));    
        scanf("%s %s",schar1,schar2);
          a=strlen(schar1);
          b=strlen(schar2);
        
          //反转赋值
          for(i=0; i<a; i++)
              sint1[a-1-i]=schar1[i]-‘0‘;
         
          for(i=0; i<b; i++)
              sint2[b-1-i]=schar2[i]-‘0‘;
          //将a定义为a,b中最大的
          if(a<b){
           t=a;
           a=b;
           b=t;
          }
          //判断是否进位
          for(i=0;i<=a;i++){
          sint1[i]+=sint2[i];
          if(sint1[i]>=10){
           sint1[i]-=10;
          sint1[i+1]++;
          }
          }
          
          printf("Case %d:\n%s + %s = ",k,schar1,schar2);
          //判断是否有进位,不同情况不同输出
                if(sint1[a]==0){
        for(i=a-1;i>=0;i--)
                        printf("%d",sint1[i]);
                        printf("\n");
                }        
                if(sint1[a]!=0){
                 for(i=a;i>=0;i--)
                        printf("%d",sint1[i]);
                        printf("\n");
                }                
                if(k!=n) printf("\n");   //最后一个不换行            
    }
     }
 return 0;
}

大数A+B 【杭电-1002】 附题,布布扣,bubuko.com

大数A+B 【杭电-1002】 附题

标签:acm   c语言   strlen   杭电   sizeof   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/38302757

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!