码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1398 Square Coins

时间:2016-05-02 22:38:55      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:

Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 

There are four combinations of coins to pay ten credits: 
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 
Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
Sample Input
2 10 30 0
Sample Output
1 4 27

 一个很标准的母函数题目,唯一需要改变的就是把+i写成+i*i 因为题意是平方倍的增加

#include<stdio.h>
#include<iostream>
using namespace std;
int n;
int a[301],b[301];
int main()
{
    while(cin>>n)
    {

        if(n==0) break;
        for(int i=0;i<=n;i++)
        {
            a[i]=1;
            b[i]=0;
        }
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                for(int k=0;k+j<=n;k+=i*i)
                {
                    b[k+j]+=a[j];
                }
            }
            for(int z=0;z<=n;z++)
            {
                a[z] = b[z];
                b[z] = 0;
            }
        }
        cout<<a[n]<<endl;
    }
    return 0;
}

 

 

HDU1398 Square Coins

标签:

原文地址:http://www.cnblogs.com/yinghualuowu/p/5453232.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!