码迷,mamicode.com
首页 > 其他好文 > 详细

2016 省热身赛 Cylinder Candy

时间:2016-05-03 00:27:07      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

Cylinder Candy
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
 

Description

Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm.

The candy center needs to be covered with a uniform coat of chocolate. The uniform coat of chocolate is d mm thick.

You are asked to calcualte the volume and the surface of the chocolate covered candy.

 

Input

There are multiple test cases. The first line of input contains an integer T(1≤ T≤ 1000) indicating the number of test cases. For each test case:

There are three integers r, h, d in one line. (1≤ r, h, d ≤ 100)

Output

For each case, print the volume and surface area of the candy in one line. The relative error should be less than 10-8.

Sample Input

2
1 1 1
1 3 5

Sample Output

32.907950527415 51.155135338077
1141.046818749128 532.235830206285
本题目表示没学过,,这个题目积分1个多小时,发现没学过。。。这个方法。。
还是数学专业的好。。
#include<stdio.h>  
#include<math.h>  
#define PI acos(-1.0)  
int main()  
{  
    int T;  
    scanf("%d",&T);  
    while(T--)  
    {  
        double r,h,d;  
        double v,s;  
        scanf("%lf%lf%lf",&r,&h,&d);  
        v=PI*PI*r*d*d+4.0/3*PI*d*d*d+2*PI*r*r*d+PI*h*((d+r)*(d+r));  
        s=2*(PI*PI*r*d+2*PI*d*d+PI*r*r+PI*h*(r+d));  
        printf("%.12lf %.12lf\n",v,s);  
  
    }  
    return 0;  
}  

 


2016 省热身赛 Cylinder Candy

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5453512.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!