码迷,mamicode.com
首页 > 其他好文 > 详细

2016 省热身赛 Find the Spy

时间:2016-05-03 00:25:46      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:

Find the Spy
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
 

Description

Whoooa! There is a spy in Marjar University. All we know is that the spy has a special ID card. Please find him out!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains a integer N (3 <= N <= 100), which describes that there are N students need to be checked.

The second line contains N integers indicating the ID card number of N students. All ID card numbers are 32-bit integers.

Output

For each test case, output the ID card number which is different from others.

Sample Input

3
10
1 1 1 1 1 1 1 1 6 1
3
9 9 8
5
90016 90016 90016 2009 90016

Sample Output

6
8
2009
水体一枚
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;

const int maxn=105;
int a[maxn];

int main()
{
     int t;
     scanf("%d",&t);
     while(t--)
     {
         memset(a,0,sizeof(a));
         int n;
         scanf("%d",&n);
         int tmp=0;
         scanf("%d",&a[0]);
         tmp=a[0];
         for(int i=1;i<n;i++)
         {
             scanf("%d",&a[i]);
         }
         for(int i=1;i<n;i++)
         {
             if(a[1]!=a[0])
         {
             if(a[2]==a[0])printf("%d\n",a[1]);
             else printf("%d\n",a[0]);
             break;
         }
             if(a[i]!=tmp&&i>1)
             {
                 printf("%d\n",a[i]);break;
             }
         }

     }
return 0;
}

 


2016 省热身赛 Find the Spy

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5453476.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!