码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3254:Corn Fields(状态压缩)

时间:2014-05-07 05:46:43      阅读:323      评论:0      收藏:0      [点我收藏+]

标签:poj   dp   

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can‘t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
 
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,m;
int a[15][15],dp[15][1<<12],v[1<<12];
const int mod = 100000000;

void init()
{
    int i,l = 0;
    for(i = 0; i<(1<<12); i++)
    {
        if((i & i<<1) == 0)//选出所有相邻不等的状态
            v[l++] = i;
    }
}

int check(int x,int p)
{
    for(int i = 1; i<=m; i++)
        if((p & 1<<(i-1)) && !a[x][i])//不能放的地方放了
            return 1;
    return 0;
}

int main()
{
    int i,j,k;
    init();
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 1; i<=n; i++)
            for(j = 1; j<=m; j++)
                scanf("%d",&a[i][j]);
        memset(dp,0,sizeof(dp));
        for(i = 1; i<=n; i++)
        {
            for(j = 0; v[j]<(1<<m); j++)
            {
                if(check(i,v[j])) continue;
                if(i == 1)
                {
                    dp[i][j] = 1;
                    continue;
                }
                for(k = 0; v[k]<(1<<m); k++)
                {
                    if((v[j]&v[k]) == 0)//与上一行没有相邻的
                        dp[i][j]+=dp[i-1][k];
                }
            }
        }
        __int64 ans = 0;
        for(i = 0; v[i]<(1<<m); i++)
            ans = (ans+dp[n][i])%mod;
        printf("%I64d\n",ans);
    }

    return 0;
}

POJ3254:Corn Fields(状态压缩),布布扣,bubuko.com

POJ3254:Corn Fields(状态压缩)

标签:poj   dp   

原文地址:http://blog.csdn.net/libin56842/article/details/25008239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!