码迷,mamicode.com
首页 > 其他好文 > 详细

Moving Tables

时间:2016-05-03 14:19:15      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5289 Accepted Submission(s): 1477
 
Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 
技术分享
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 
技术分享
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 
Sample Input
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 
 
Sample Output
10
20
30
 

 

习题总结:

  虽然是第二次做这道题目,但是还是WA了2次,,还是原来的原因,,好坑人的题目。。。

 

一定要注意,改变的数组位置要记录下来。。。

# include <iostream>
# include <cstdio>
# include <algorithm>
# include <vector>
using namespace std;
struct Info
{
    int start, end;
    int m;
};
bool cmp(Info a, Info b)
{
    if(a.start != b.start)
        return a.start < b.start;
    else
        return a.end < b.end;
}
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        Info info;
        vector <Info> v;
        int n;
        cin >> n;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &info.start, &info.end); // cin >> info.start >> info.end;
            info.start = (info.start + 1) / 2;
            info.end = (info.end + 1) / 2;

            if(info.start > info.end)
                swap(info.start, info.end);

            info.m  = 0;
            v.push_back(info);
        }
        sort(v.begin(), v.end(), cmp);
        // cout << v[0].start << " " << v[1].start << endl;
        int jishu = 0;
        for(int i = 0; i < v.size(); i++)
        {
            if(v[i].m == 0)
            {
                jishu++;
                v[i].m = 1;
                int tep = i;// 就是这里必须要记住,,记录I的位置
for(int j = i + 1; j < v.size(); j++) { if(v[j].m == 0) { if(v[j].start > v[tep].end) { v[j].m = 1; tep = j; } } } } } printf("%d\n", jishu * 10); } return 0; }

 

Moving Tables

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5454498.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!