码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3605 Escape (二分图多重匹配)

时间:2014-07-30 20:52:14      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   strong   

Escape

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4298    Accepted Submission(s): 1129


Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
1 1 1 1 2 2 1 0 1 0 1 1
 

Sample Output
YES NO
 

Source

多重匹配即 X 集合上的点对应 Y 集合上多个点 Y 集合上的点对应 X 中的一个点.

可以用一个二维数组记录匹配的对象link[M][N],再用一个数组cnt[M]记录该点已经匹配几个点了,是否超出最大匹配,若超出最大匹配,则在该点已经匹配的点中寻找增广路径。

若某个点不能匹配成功,则查找失败。。

#include"stdio.h"
#include"string.h"
#define N 100005
#define M 15
bool g[N][M],vis[M];          //存边的权值0、1,记录是否访问过
int lim[M],cnt[M],link[M][N];  
int n,m;
int find(int k)
{
    int i,j;
    for(i=0;i<m;i++)
    {
        if(!vis[i]&&g[k][i])
        {
            vis[i]=1;
            if(cnt[i]<lim[i])
            {
                link[i][cnt[i]++]=k;
                return 1;
            }
            for(j=0;j<cnt[i];j++)
            {
                if(find(link[i][j]))
                {
                    link[i][j]=k;
                    return 1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        memset(g,0,sizeof(g));
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                scanf("%d",&g[i][j]);
            }
        }
        for(i=0;i<m;i++)
        {
            scanf("%d",&lim[i]);
        }
        memset(link,0,sizeof(link));
        memset(cnt,0,sizeof(cnt));
        for(i=0;i<n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(!find(i))
                break;
        }
        if(i==n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


hdu 3605 Escape (二分图多重匹配),布布扣,bubuko.com

hdu 3605 Escape (二分图多重匹配)

标签:des   style   blog   http   color   java   os   strong   

原文地址:http://blog.csdn.net/u011721440/article/details/38304889

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!