码迷,mamicode.com
首页 > 其他好文 > 详细

LA 4253 Archery (二分)

时间:2016-05-05 11:08:09      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:

Korea‘s reputation in archery is well known because the Korean archery teams have been sweeping almost all gold, silver, and bronze medals in the Olympic Games.

An archery game ICPC supported by NEXON (one of Korea‘s leading publishers of online contents) will be held in Korea. As a ceremonial event of the game, a famous master of archery will shoot an arrow to hit through all target boards made of paper. Because an arrow flies along a straight line, it depends on his position of the archer line whether or not he hits all targets.

The figure below shows an example of the complete view of a game field from the sky. Every target is represented by a line segment parallel to the archer line. Imagine the coordinate system of which the origin is the leftmost point of the archer line and the archer line is located on the positive x -axis.

技术分享

In the above figure, the master can hit all targets in position B. However, he never hits all targets in position A because any ray from A intersects at most 3 targets.

Given the width of the archer line and the target locations, write a program for determining if there exists a position at which the master can hit all targets. You may assume that the y -coordinates of all targets are different. Note that if an arrow passes through an end point of a target, it is considered to hit that target.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T(1技术分享T技术分享30) is given in the first line of the input. Each test case starts with a line containing an integerW (2技术分享W技术分享10, 000, 000) , the width of an archer line. The next line contains an integer N (2技术分享N技术分享5, 000) , the number of target boards. The i -th line of the following N lines contains three integers Di , Li , Ri (1技术分享Di技术分享W, 0技术分享Li < Ri技术分享W) , where 1技术分享i技术分享N , Di represents the y -coordinate of the i -th target, and Li andRi represent the x -coordinates of the leftmost point and the rightmost point of the target, respectively. Note that Di 技术分享 Dj if i 技术分享 j .

Output 

Your program is to write to standard output. Print exactly one line for each test case. Print ``YES" if there exists a position on the archer line at which a master of archery can hit all targets, otherwise, ``NO".

The following shows sample input and output for three test cases.

Sample Input 

3 
15 
4 
10 2 7 
7 5 12 
2 7 12 
4 9 13 
6 
3 
2 1 3 
4 0 2 
5 4 6 
10 
4 
8 2 5 
4 2 5 
6 5 8 
2 5 8

Sample Output 

YES 
NO 

YES

题目大意:给你一堆靶子,每个靶子是一段区间并有自己的高度,问你能不能在给定区间内找一条直线把这些靶子全部串起来。

分析:看了网上的题解才知道做法,二分射箭的位置,然后维护一段仰角的区间,如果一个靶子在当前区间左边则向左移动,在右边则向右移动。

#include <cmath> 
#include <cstdio>
#include <iostream>
#include <algorithm>
#define max(a,b) a > b ? a:b
#define min(a,b) a > b ? b:a
#define eps 1e-9
#define pi 4*atan(1.0)
using namespace std;
int n,w,T;
struct thing 
{
	int d,l,r;
} tar[5001];
bool cmp(thing a,thing b)
{
	return a.d < b.d;
}
int check(long double x)
{
	long double L = 0,R = pi;
	for(int i = 1;i <= n;i++)
	{
		long double l = atan2(tar[i].d,tar[i].r - x);
		long double r = atan2(tar[i].d,tar[i].l - x);
		if(fabs(r - L) > eps && r < L) return -1;
		if(fabs(R - l) > eps && l > R) return 1;
		L = max(L,l);
		R = min(R,r); 
	}
	return 0;		
}
using namespace std;
int main()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&w);
		scanf("%d",&n);
		for(int i = 1;i <= n;i++) scanf("%d %d %d",&tar[i].d,&tar[i].l,&tar[i].r);
		sort(tar+1,tar+1+n,cmp);
		bool flag = false;
		long double l = 0,r = w;
		while(fabs(l - r) > eps)
		{
			long double mid = (l+r)/2;
			int num = check(mid);
			if(num == 1) l = mid;
			else 
			 if(num == -1) r = mid;
			 else 
			 {
		       	flag = true;
		       	break;
			 }
		}
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
} 


LA 4253 Archery (二分)

标签:

原文地址:http://blog.csdn.net/u014258433/article/details/51319737

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!