码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 动态规划 O

时间:2016-05-05 14:40:54      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:

Problem O

Time Limit : 1000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 23 Accepted Submission(s) : 20
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1
2
3
 
Sample Output
1
10
11
 
 
把十进制变成2进制
#include<iostream>
using namespace std;
int main()
{
    int n;
    int b[11];
    while (cin >> n)
    {
        if (n == 0)
        {
            cout << "0" << endl;
            continue;
        }
        int k = 0;
        while(n)
        {
            b[k++] = n % 2;
            n /= 2;
        }
        for (int i = k - 1; i >= 0; i--)
            cout << b[i];
        cout << endl;
    }
    return 0;
}

 

HDU 动态规划 O

标签:

原文地址:http://www.cnblogs.com/lyf-acm/p/5461655.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!