标签:
Description
Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.
The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.
At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.
For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn’t jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.
Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.
Now they want to find out the maximum turns they can play if they follow the optimal strategy.
Input
The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.
Output
For each test case, print a integer denoting the maximum turns.
Sample Input
1
1
4
1 1 2 1
6
2 1 1 2 1 3
0
Sample Output
1
4
5
Hint
For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2. For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5.
两只兔子在一个圈上跳,一只逆时针跳,一只顺时针跳。每只兔子跳的位置的权值必须相同,且兔子不能跳过其起点(不能超过一圈),问他们所经过的位置最长有多长?
区间dp求不连续的回文子序列。
将这个环看作链,链中每一个元素都可以当作起点,将这起点左右dp值得和都求出来取最大值。
dp[i][j]表示在i到j之间的回文序列的最大长度。
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
const int MAXN=1010;
using namespace std;
int n;
int a[MAXN];
int dp[MAXN][MAXN];
int main()
{
while(scanf("%d",&n)!=-1 && n)
{
for(int i=1; i<=n; i++)
{
scanf("%d",&a[i]);
}
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
dp[i][i]=1;
for(int i=n-1; i>0; i--)
{
for(int j=i+1; j<=n; j++)
{
dp[i][j]=max(dp[i+1][j],dp[i][j-1]);
if (a[i]==a[j]) dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
//这个状态转移方程是在链中的方程
}
}
int ans=0;
for(int i=1; i<=n; i++) ans=max(ans,dp[1][i]+dp[i+1][n]);//枚举环中的起点,加上左右两边
printf("%d\n",ans);
}
return 0;
}
标签:
原文地址:http://blog.csdn.net/wuxuanyi27/article/details/51328732