码迷,mamicode.com
首页 > 其他好文 > 详细

Radar

时间:2016-05-06 12:50:25      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:

Radar

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 技术分享

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
来源
Beijing 2002
上传者

ctest




 
/*
题意:给定点集S={(xi,yi)i=1.2.3...n},求用圆心在x轴上,半径为r的圆覆盖S所需的圆的最少个数。
解题思路:先把给定的xi,yi,r转化为x轴上的区间,即圆心所在的区间,这样就转化为了区间选点问题。
先对右端点从小到大排序,右端点相同时,左端点从小到大排序。


每一个点以r为半径,在x轴上的投影的区间段。即是该区间段上任一点部署雷达,都可以覆盖岛屿。
 
*/ 
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct radar{
double a,b;
}r[1005];
bool comp(radar a1,radar a2)
{
if(a1.b!=a2.b)//对右端点从小到大排序
return a1.b<a2.b;
return a1.a<a2.a;//右端点相同,左端点从小到大排序 
}
int main()
{
int n,d,i,cas=0;
while(scanf("%d%d",&n,&d),n,d)
{
double x,y;
int flag=0,m=0;
for(i=0;i<n;++i)
{
scanf("%lf%lf",&x,&y);
if(fabs(y)>d)
{
flag=1;//高度大于半径,有覆盖不到的点  
continue;
}
double diff=sqrt(d*d-y*y);
r[m].a=x-diff;
r[m++].b=x+diff;
}
printf("Case %d: ",++cas);
if(flag)
{
printf("-1\n");
continue;
}
sort(r,r+m,comp);
int cnt=1,p=0;

for(i=1;i<m;++i)
{
if(r[p].b>=r[i].a)
{
continue;
//区间重叠,不换 雷达 
}
else{
cnt++;
p=i; 

}
printf("%d\n",cnt);
}
return 0;
}         


Radar

标签:

原文地址:http://blog.csdn.net/gz153016/article/details/51328907

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!